[Fix] Moto E 1st Gen Dual SIM No Sim Card Problem

MOTO E NO SIM CARD FIX

Moto E first generation sim card not detecting problem fix
Moto E
First you need to ensure that you have a custom recovery like TWRP or clockworkmod must be installed on your mobile. And the bootloader of the phone must be unlocked. If all the conditions are fine, then download the following file


After that, place the file in your SD card, then load the recovery, and do the following

- Choose 'Install zip'
- Locate and install the file from SD card
- Clear cache and dalvik cache
- Reboot the phone
- Done.

Now the problem is solved. If you have any concerns just comment here.
[Fix] Moto E 1st Gen Dual SIM No Sim Card Problem [Fix] Moto E 1st Gen Dual SIM No Sim Card Problem Reviewed by Tech Doubts on 7:29 AM Rating: 5

27 comments:

  1. Hi Can you please explain the steps clearly.
    And, is this fix only for Rooted Moto-E phones ?
    Bcoz I'm also facing the same problem but never rooted my phone.
    Thanks in Advance.

    ReplyDelete
    Replies
    1. Yes, this is for rooted phones, and have you installed any custom recoveries like CWM, TWRP in your phone?

      Delete
  2. Replies
    1. Hi Kunal,

      Checkout here https://www.quora.com/How-do-I-root-the-Moto-E-1st-generation-What-are-the-steps. Full method with screenshots provided.

      Delete
  3. when i try to flash new rom using twrp it just says done but nothing happens even when i try to format it says the same damn thing

    ReplyDelete
    Replies
    1. Is your bootloader is in unlocked state? Have you checked that?

      Delete
  4. will work with a fully rooted, unlocked moto e running on Cyanogen Mod 14??

    ReplyDelete
    Replies
    1. Yes.. I also done in a fully rooted Moto E 1st generation mobile.

      Delete
  5. thanks a lot ..you saved my day!! after trying all the alternatives i could possibly think of ..and then suddenly i saw a solution on your site which made my day...cheers:)

    ReplyDelete
  6. After two days of no sleep, hours of pulling my hair, this finally saved this phone from being thrown away. Tried many ways to solve the problem without success, from restarting my phone, factory reset, to even flashed 3 different ROMs. All of that didn't work out. But this one here, well, you just saved my day.. Currently running CM13 and everything works like charm.
    *Thanks big time, Bless!!!*

    ReplyDelete
  7. I did all the steps. It worked for few days or up to when mobile gets switch off...once it get on again the same error....what to do??

    ReplyDelete
    Replies
    1. Just re-install that zip. May be any files missed.

      Delete
  8. Thank You SOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO MUCH TECH DOUBT BRO..........YOU SAVED THE DAY!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    ReplyDelete
  9. hello ... yesterday i unlocked my bootloader .. then i rooted my moto e successfully.. then i install cm 14 rom with cwm recovery .. all going well but dual sim not working in my cell ... kindly help as early as possible.

    ReplyDelete
    Replies
    1. Hello Varun,

      Is single SIM is working?

      Delete
  10. Hello I had rooted the device, suddenly facing issue to detect the sim cards. I had flashed the radio files but still face the same issue. Could you please help me?

    ReplyDelete
    Replies
    1. Flashing radio must work. Are you from India or other country?

      Delete
  11. I have a Moto E for abt 10 months and today while I was using my phone (actually playing) my phone suddenly hangs so I restarted with long pressing power button but after restart phone went into several bootloop. After around 6 bootloop it went into the homescreen. Then I found that wifi screen always showed "turning wifi on" and I cant turn it off/on. Same thing with bluetooth and the worst part is both sims not working. It said no service

    Now please help me how to recover from this problem.

    ReplyDelete
    Replies
    1. You need to re-ROM your Moto E phone to solve this problem. Just go to here for full tutorial https://forum.xda-developers.com/moto-e/general/root-moto-e-rooting-flashing-recovery-t2802971

      Delete
  12. Thanku so much yar!

    ReplyDelete
  13. I usually don't comment on forums and solutions but man thank you so much...you're savior ...you revoked this device...tysm

    ReplyDelete

Powered by Blogger.